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Summary 

Proboard 21J systems are Arduino1 compatible 
circuit boards based on Microchip’s SAMD21 
microcontroller. The design provides direct 
breadboard pin access for all functions of the 
SAMD21 ARM Cortex processor and supports easy 
interfacing with external devices. 

21Js are ideal to use in educational or hobby 
electronics projects, or can be used as components 
in professional battery powered devices such as 
test instruments. Software functions include an 
ability to disconnect power from the onboard power 
indicator LED and the addressable RGB LED when 
used in ultra-low-power portable applications. 

See the Programming section for a quick start 
guide showing how to program a 21J using Arduino 
sketches, or for how to use CircuitPython. 

Features of the Proboard21J: 

 ATSAMD21J18A microcontroller
 USB Flashing Format (UF2) bootloader preinstalled
 Quartz crystal timing, ±20 parts per million accuracy
 10 pin Serial Wire Debug (SWD) connector
 SWD connections accessible via breadboard pins
 USB-C connection for device programming
 Onboard 4MB SPI flash memory for use as a mini

hard disk while running CircuitPython
 An onboard addressable RGB LED
 Fully compatible with the Arduino1 Integrated

Development Environment (IDE)
 20 digital I/O pins, 6 analog inputs, 12 PWM outputs
 Onboard +3.3 VDC voltage regulator accepts

+5VDC to12VDC input
 256KB flash memory - 8K used for bootloader
 Dimensions: 46.99mm x 12.19mm (1.85in x 0.48in)
 Weight: 4.7g
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1. Pinouts

Figures 1-3 are pinout diagrams for P1 (36 header pin plug), J1 (USB-C jack) and J2 (SWD jack). 

Figure 1  P1 Header Pins 

https://www.heroncircuits.com
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Figure 2  J1 USB-C Interface 

Figure 3  J2 SWD Interface 

https://www.heroncircuits.com
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2. Schematic

Figure 4  Proboard 21J Schematic 

U1 = ATSAMD21J18A 
U2 = Transistor Switches 
U3 = Addressable RGB LED 
U4 = 3.3V Regulator 
U5 = 4MB SPI Flash 

https://www.heroncircuits.com
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3. Signal Descriptions

Table 1  Header Pins 

Pin Name Description 

+V Input into the onboard voltage regulator, +5VDC  to +12VDC  

3V Regulated +3.3VDC output from the onboard voltage regulator 

GD Ground pin 

0 Digital Input / Output (I/O) pin, or receive serial data (RX) 

1 Digital I/O pin, or transmit  serial data (TX) 

2 to 13 Digital I/O pins 

CL Serial Clock (SCL) pin for the Inter-integrated Circuit (I2C) interface 

DA Serial Data (SDA) pin for the I2C interface 

A0 to A5 Combination analog or digital I/O pins, also known as digital pins 14 to 19 

AR Analog Reference 

SC Serial Wire Debug (SWD) interface Clock (CLK) pin (SWCLK) 

SD Serial Wire Debug (SWD) interface Data Input / Output (DIO) pin (SWDIO) 

RS External input to /RESET 

Others The remaining pins form an interface for connecting an SD memory card. See Figure 1. 

4. Powering Proboard 21J

Users have three options for supplying power. 

 Connect the positive terminal of a +5VDC to +12VDC power supply to the pin marked +V, and
connect the negative terminal of the power supply to either of the GD connections.

 Connect a regulated +3.3VDC power source to either of the pins marked 3V and ground. The
output of the Proboard’s onboard voltage regulator is protected by an internal output blocking diode.
An externally applied voltage will not feed current back into the unused onboard voltage regulator.
Just be certain the external source is a regulated supply that does not exceed +3.3VDC.

 The easiest option is to plug one end of a USB-C to USB-A data cable into the onboard USB-C
jack, and plug the other end into the USB-A port of a PC. The Proboard 21J onboard voltage
regulator will convert the +5V USB bus power into +3.3V for powering the SAMD processor.

For pins other than +V, avoid connecting any of the pins to voltages greater than +3.3VDC! 

https://www.heroncircuits.com
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5. Connecting an SD Card

Use an SD card to micro SD adapter as shown in Figure 5, below. This works well for data logging. 
See examples in the Programming section for how to write data to SD memory cards. 

Figure 5  Installing a micro SD Card Adapter 

Seven of the pads on the back of an SD card are spaced at 2.50 mm intervals. This is similar to the 
0.1 inch (2.54 mm) pin spacing for a standard breadboard, so users can install an SD card as a 
memory module by soldering seven pins with 0.1 inch pin spacing to the back of the card. See the 
positioning in Figure 6. Note that pads 7 and 8 must not be shorted. Be careful not to plug any pin 
into the +V connection. Avoid plugging the module in backwards when installing it into the 
breadboard as shown in Figure 5. 

Figure 6  Pins for a micro SD Card Adapter 

+5V to +12V 

Ground 

Right-angle Pins 

Straight Pins 

https://www.heroncircuits.com
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6. Programming

Navigate to https://www.arduino.cc/en/main/software where you can download the Arduino IDE to 
your computer. Choose the option pictured in Figure 7 if you need the Windows 10 EXE installer. 

Figure 7  Downloading the Arduino IDE 

You will need to provide information to the Arduino IDE so it can support using all features and 
functions of a SAMD processor. The order of the installation steps is important. 

In a later step, you will need to install “Arduino SAMD Boards (32-bits ARM Cortex-M0+).” 
In tests, we noticed that installing Arduino SAMD Boards can generate error messages that do not 
happen if a related Adafruit support package is installed first. 

So, install the Adafruit support package first. Then, install the Arduino SAMD Boards package. 
Then, lastly, install the SAMD board files from Heron Circuits. The installation can sound 
complicated, but it is short and easy. Do and check off each step as listed here. 

First, the Arduino IDE needs two links added to its configuration. Select “File>Preferences.” 
In the text box marked “Additional Boards Manager URLs” add the following text: 

https://adafruit.github.io/arduino-board-index/package_adafruit_index.json, 
https://files.heroncircuits.com/proboard-index/package_heroncircuits_index.json 

If you already have other .json files linked in this same text box, keep them installed. Just remember 
to separate each Uniform Resource Locator (URL) with a comma. 

Select “OK.” 

Choose “Tools>Board:>Boards Manager…” In the “Type” drop-down menu, select “All.” 
Feed "Adafruit SAMD" into the search box. Hits will start appearing before you type all of it. 

Type all of it. You will see two hits. Begin with the second item on the list. 

Point to “Adafruit SAMD Boards.” Click “Install.” 
While this installation runs, the Arduino IDE can display a warning that it ignored a script. 
Ignore the warning. 

Click here. 

https://www.heroncircuits.com
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If “Adafruit SAMD Boards” is not listed, check your firewall and make sure your firewall allows the 
Arduino IDE full access to the internet connection so the Boards Manager can succeed. 

The progress bar moves slowly, but this is normal. After the Adafruit SAMD Boards installation is done, 
next point to “Arduino SAMD Boards (32-bits ARM Cortex-M0+).” Click “Install.” During installation, 
depending on preferences set in each Windows computer, the Windows operating system can interrupt 
several times asking for reassurances that it is OK to make changes. Click yes each time until you see a 
message confirming that the installation is finished. Do not click “Close” yet. 

Next, feed "Heron Circuits" into the Boards Manager search box, and press “Enter.” 

Point to “Heron Circuits SAMD Boards” and click “Install.” 

If you also have a Proboard PB system based on the ATmega328PB microcontroller, you can 
optionally install Heron Circuits AVR boards support here. 

Select “Close” when finished. Now, the Arduino IDE has new menu items available. 

For using a Proboard 21J, select “Tools>Board:>Heron Circuits Proboard 21J. 

In a moment you will choose “Tools>Port” for selecting the serial port. To identify the correct port 
number for the Proboard 21J, first unplug the Proboard 21J’s USB data cable from the PC and note 
any serial devices already present on the “Tools>Port” list. Then, plug the Proboard 21J’s USB 
cable back into the PC’s USB port and double press the Proboard 21J’s “/RESET” button. This 
makes certain the 21J is in bootloader mode. In later operations while uploading Arduino sketches, 
always remember to double press the reset button on the 21J to place it into bootloader mode 
before uploading any new sketch. This makes the com ports match up automatically. 

With the USB cable reconnected, look for the extra serial port that appears on the “Tools>Port” 
menu. The new option that appears will be the one for the Proboard 21J. Other than being new, it 
should also have “(Heron Circuits Proboard 21J)” written beside it as part of the name. Select it. 

Open the “File>Examples>01.Basics>Blink” sketch to test your system. Upload Blink by choosing 
“Sketch>Upload.” You will see a “Done Uploading” message appear in the IDE status bar. The Blink 
sketch flashes a small white LED at the end of the board. 

Please complete this part of the setup first. Confirm the Arduino IDE is fully installed and working 
before doing other operations such as updating the bootloader or installing CircuitPython. 

https://www.heroncircuits.com
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7. Updating the UF2 Bootloader

Each Proboard 21J is manufactured with a USB Flashing Format (UFF or UF2) bootloader resident 
in the lowest 8K of the processor memory. When using the Arduino IDE or CircuitPython it should 
never be necessary to erase the UF2 bootloader, but it can be modified in two possible ways. First, 
by using nothing more than a Windows PC and a USB-C data cable, the bootloader can update 
itself to a later version, thus providing an easy path for updates. 

In the second case, it is possible to use a hardware debug probe such as a Segger J-Link to erase 
the UF2 bootloader. This is done if using Microchip Studio software to compile and install programs 
designed to take up all memory of the processor – including the bit of memory normally populated 
by the bootloader. Memory in the SAMD21 processor is huge, and all of its functions are accessible 
with a bootloader installed, so programming it without a bootloader is not covered in this datasheet. 
For users who need that ability, the Heron Circuits website will maintain files showing how to 
program a Proboard 21J in a variety of ways without a bootloader. 

The preinstalled UF2 bootloader is version 3.12.0. It should perform all functions without ever 
needing to be replaced, but if required the newest version will always be here: 

https://files.heroncircuits.com/archives/Newest_Bootloader_Proboard_21J.zip 

In the file name, the under bar character (“_”) is between words. The zip file contains two formats, 
bin and uf2. Updating is accomplished by using the uf2 file. The process is astonishingly easy. 

Simply download and open the zip archive using any unzip program. Connect the Proboard 21J to 
the PC using a USB-C data cable. Double press the reset button to put the Proboard into 
bootloader mode. In Windows File Explorer, the Proboard 21J will appear as a new virtual disk 
named “PROBOOT.” Now, use the mouse to drag the uf2 file from the archive and drop it onto the 
new virtual disk name. Windows shows a progress bar indicating a file transfer. Proboard 21J 
reboots itself using the newest bootloader. That’s it. “Drag and drop” with the mouse installs the 
new bootloader by using a smart phone data cable. 

Before performing the update, you can check the current version number for the bootloader already 
installed. Double press the reset button. When the PROBOOT disk name appears in Windows File 
Explorer, double click on the disk name. The file inside named “INFO_UF2.TXT” contains the 
version information. The files in the PROBOOT virtual disk are returned to their factory default 
configurations by the bootloader each time it is rebooted, so do not bother editing or deleting them. 
They are quite indestructible, like Captain Scarlet. 

The bin file version of the bootloader is also included in the zip archive in case Microchip Studio and 
a debug probe are ever used to completely erase an installed bootloader. In that case, Microchip 
Studio needs the bin file for installing a fresh bootloader into a totally erased system. The uf2 
version works for drag and drop replacement of a working bootloader that is already installed. 

https://www.heroncircuits.com
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8. Installing CircuitPython

Before installing CircuitPython, please read and perform the steps in the previous section for 
updating the bootloader. Installing CircuitPython is quite similar and will be much easier to 
accomplish after first warming up with the bootloader update. In order to install CircuitPython, 
download the CircuitPython installation zip file at the following link: 

https://files.heroncircuits.com/archives/Newest_CircuitPython_Proboard_21J.zip 

Open this zip file using any unzip program. Connect the Proboard 21J to the PC using a USB-C 
data cable. Double press the /RESET button of the Proboard to put it into bootloader mode. In 
Windows File Explorer, the Proboard will appear as a virtual disk named “PROBOOT.” Use the 
mouse to drag the uf2 file from the CircuitPython archive and drop it onto the virtual disk. Windows 
shows a progress bar indicating a file transfer. CircuitPython starts running on the Proboard 21J. 

While CircuitPython is running, it changes the name of the virtual disk seen in Windows File 
Explorer from “PROBOOT” to “CIRCUITPY.” The Proboard 21J has a non-volatile memory chip 
onboard just for storing CircuitPython scripts and related library files. Double clicking on the 
“CIRCUITPY” disk name opens a new virtual disk showing files stored in the memory chip. 

Figure 8  CIRCUITPY Initial Files 

If CircuitPython was never previously installed, it will set up the CIRCUITPY virtual disk’s content as 
shown in Figure 8. Note the disk has a single “code.py” example script. The file “boot_out.txt” 
contains version information. Files that begin with a dot “.” in their names are used by the system to 
keep track of metadata, and should not be modified or deleted. The “lib” folder is empty at this point.

https://www.heroncircuits.com
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Along with the CircuitPython UF2 installer, files in the zip archive include extra Python script 
examples and a “lib” folder full of libraries created by Adafruit Industries. In the CIRCUITPY disk, 
delete the empty “lib” folder. Next, copy all zip file contents except the UF2 file into the CIRCUITPY 
virtual disk. The result will look like Figure 9. The full 2MB lib folder needs about seven minutes to 
copy. The library is too big to fit into a typical 2MB Serial Peripheral Interface (SPI) memory chip, 
but this is not a problem for the Proboard 21J. It has a double-sized 4MB chip, and fits everything. 

Figure 9  Example Python Scripts 

CircuitPython is an interpreter. Each time it starts running, it immediately executes the Python script 
instructions in the “code.py” file. To run any other example script, delete the existing “code.py” file. 
Then, copy and rename a copy of the desired example file to make a new “code.py” file. Any time 
the content of the CIRCUITPY virtual disk changes, CircuitPython reloads the available “code.py” 
file and reruns the Python script stored inside. There is no wait for compiling. The code runs NOW. 

The example “code - off.py” shows how CircuitPython can control the Red, Green, Blue (RGB) 
colors of an onboard three-color lamp. The code sets the RGB colors to (0, 0, 0) which means 
“dark.” Using Notepad, change (0, 0, 0) to (0, 0, 255) and hit “Save” to see the brightest of blue. Try 
(255, 0, 0) to see a bright red. Smaller numbers are less bright. 255 is the maximum. 

The example file “code - sd.py” shows how CircuitPython can write data onto an external secure 
data (SD) card as pictured in Figure 5. If you run this data logger example with no SD card 
connected, it turns the multicolor light red. If it finds a valid SD card, it turns the light green. The SD 
card should be formatted as a single FAT32 partition no bigger than 32GB. 

Pressing the /RESET button once causes CircuitPython to restart the “code.py” script. 
Pressing /RESET twice causes the bootloader to take over instead of CircuitPython. 

https://www.heroncircuits.com
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9. Low Power Applications

We solved a problem we noticed when using the SAMD21 processor in low power modes. Various 
different methods allow placing a SAMD21 in sleep modes where the chip can be awakened by external 
events such as button presses, or by the cycling of a watch dog timer. Showing the many ways of 
configuring low power modes is beyond the scope of this datasheet, but we found a related problem. 

The onboard RGB LED includes a small integrated circuit inside the device that continues to consume 
about 1.0 mA of current – even if all three colors of the RGB LED are set for zero output. In portable 
applications it can kill batteries quickly regardless of placing the main processor into sleep modes. 

The multicolor pixel is useful when running CircuitPython because the colors and the blinking patterns 
have special meanings that help with CircuitPython code debugging. We did not want to get rid of the 
addressable RGB LED, or replace it with a tiny power miser version as a compromise.

The solution is visible in the schematic in Figure 4 (on page 4). The hardware of the Proboard 21J has 
two extra pins that are not available on similar boards such as an Arduino Zero or with other devices 
using a 48 pin version of the SAMD21 processor. The Proboard 21J uses a 64 pin version of the 
same processor. Two MOSFET switching transistors are connected to an extra set of pins. This 
allows switching off current into the onboard LEDs before placing the processor in sleep modes. 

Click on the image in Figure 10 to download an example for the Arduino IDE. The example code 
provided will not compile for other boards because the Arduino IDE only recognizes the uniquely named 
“SLEEP_POWER_LED” and “SLEEP_RGB_LED” pin definitions for Proboard 21J systems.

Figure 10  Disconnecting LED Power 

https://www.heroncircuits.com
https://files.heroncircuits.com/archives/Proboard_21J_Disable_LEDs.zip
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The option to use a relatively fast microcontroller with lots of memory in low power modes can support 
many new applications where fielded systems would run for long periods of time, but would be powered by 
small batteries in portable devices. Grab a breadboard. Experiment and explore. Anything is possible.

10. Additional Resources

Click on the Heron at the top of any datasheet. 

Related Products: 

https://files.heroncircuits.com/documents/Proboard_328P_Datasheet.pdf 

https://files.heroncircuits.com/documents/Proboard_PB_Datasheet.pdf 

https://files.heroncircuits.com/documents/Timeport_Datasheet.pdf 

https://files.heroncircuits.com/documents/Polaron_Datasheet.pdf 

11. Notice

IMPORTANT NOTICE – PLEASE READ CAREFULLY 

Heron Circuits reserves the right to make changes, corrections, enhancements, modifications and 
improvements to Heron Circuits products and/or to this document at any time without notice. Purchasers 
should obtain the latest relevant information on Heron Circuits products before placing orders. Heron Circuits 
products are sold pursuant to Heron Circuits’ terms and conditions of sale in place at the time of order 
acknowledgement. 

Purchasers are solely responsible for the choice, selection, and use of Heron Circuits products and Heron 
Circuits assumes no liability for application assistance or the design of the Purchaser’s products. 

No license, express or implied, to any intellectual property rights is granted by Heron Circuits herein. 

Resale of Heron Circuits products with provisions different from the information set forth herein shall void any 
warranty granted by Heron Circuits for such product. 

Information in this document supersedes and replaces information previously supplied in any prior versions of 
this document. 

https://www.heroncircuits.com



