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Summary 

Proboard PB systems (blue in color) are Arduino1 
compatible circuit boards based on the Microchip 
ATmega328PB microcontroller. 

Proboard 328Ps (green in color) are similar, but 
use the original ATmega328P microcontroller. All 
information in this datasheet is for the Proboard PB.  

Green Proboards are useful where quick setup and 
total Arduino compatibility are needed. The blue 
Proboard PBs can also be programmed by using 
the Arduino Integrated Development Environment, 
but support ATmega328PB specific functions not 
available in standard Arduino compatible systems. 

Either variant, 328P or PB, can be plugged into an 
optional Heron Circuits Timeport® accessory board 
for management of lithium polymer battery 
charging, voltage boost conversion, interfacing with 
Sideboard TM modules, or for access to automatic 
timed shutdown functions. 

Features of the Proboard PB: 

 ATmega328PB microcontroller
 Preinstalled OPTIBOOT bootloader
 Compatible with the Arduino Integrated

Development Environment (IDE)
 Polarized TTL connector for interfacing with a Heron

Circuits Polaron® FTDI USB to TTL converter
 Compatibility with generic USB to TTL converters
 Onboard In Circuit Serial Programming (ICSP) port

for burning alternative bootloaders and  fuses
 26 digital I/O pins, 7 analog inputs, 6 PWM outputs
 16MHz quartz crystal, ±10 parts per million accuracy
 Onboard voltage regulator +5.0 volts direct current

(VDC), 150mA, accepts +6VDC to16VDC input
 32KB flash memory - 0.5K used for bootloader
 Dimensions: 41.9mm x 12.2mm (1.65in x 0.48in)
 Weight: 4.3g
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SparkFun, but we recommend their products. 

https://www.heroncircuits.com


 

20210406       © 2020 Heron Circuits, LLC 2 

Proboard TM PB
Part Number HC20333

Heron 
Circuits 

www.heroncircuits.com 

1. Pinouts

Figures 1-3 are pinout diagrams for P1 (male 32 pin header plug), J1 (TTL jack) and J2 (ICSP jack). 

Figure 1  P1 Header Pins 

https://www.heroncircuits.com
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Figure 2  TTL Connections for J1 

Figure 3  CISP Connections for J2 

https://www.heroncircuits.com
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2. Schematic

The schematic below and all notes in this datasheet are for the blue Proboard PB systems which 
use the ATmega328PB microcontroller. See the “Programming” section for details on how to set up 
the Arduino IDE to support programming of Proboard PBs. 

Figure 4  Proboard PB (Blue Board) Schematic 

https://www.heroncircuits.com
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3. Configuration 

 

Figure 5  Configuration Switches 

 
Proboard PBs have two solder switches, SW1 and SW2 as shown in Figure 5, plus two extra 
disconnected pins marked *1 and *2. To find the extra pins, see the P1 pinout in Figure 1. 

The default switch configuration has a thin trace in SW1 connecting the processor’s AVCC input to 
the output of the Proboard PB’s onboard voltage regulator, VR. The solder switch SW1 can be used 
to connect the processor’s AVCC input to an alternate external voltage on pin *1. By default, SW2 
connects the processor’s analog reference, AREF, to whatever voltage a user has selected for 
AVCC by using switch SW1. SW2 can be used to disconnect AREF from AVCC, and connect AREF 
to the *2 pin. 

As shown in the figure, by default, the AVCC and AREF connections are both wired to VR which 
also powers the processor’s digital circuitry. This setup matches all standard Arduino compatible 
microcontroller boards, and for most applications there is no need to change it. The switches are 
provided to allow advanced users the freedom to solve absolutely any problem by using any 
needed processor configuration, but you should understand that making modifications involving 
cutting of traces will void the warranty. 

Proboard PBs are designed to be powered by DC +6V, +9V, or +12V fed into the pin marked “+V” 
in Figure 1. Each Proboard is warranted to be free from manufacturing defects at the time of 
manufacture, but connecting the +V pin to any voltage outside the range of 0V to +16VDC or 
connecting any of the other pins to voltages outside the range of 0V to +5.0VDC will also void the 
warranty, and probably release magic smoke, so don’t. 

The user assumes all risk associated with cutting traces by using sharp tools, and soldering using 
hot tools. Using all necessary cautions, an experienced hobbyist can cut the prewired traces by 
using the tip of a fresh hobby knife blade. Then, add a small blob of solder to connect the center 
pad to the opposite setting. Put the Proboard into a circuit board vise while being careful to avoid 
bending pins. Use a head-mounted magnifier, and good lighting 

 

SW1 

SW2 

https://www.heroncircuits.com
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4. Signal Descriptions

Table 1  Header Pins 

Pin Name Description 

RX Receive serial data 

TX Transmit  serial data 

2 to 13 Digital Input / Output (I/O) pins 

A0 to A5 Combination analog or digital I/O pins, also known as digital pins 14 to 19 

E0 Digital I/O pin, or alternately the Analog Comparator Output (ACO) 

E1 Digital I/O pin. Note that port E is not available in the ATmega328P processor. 

E2 Digital I/O pin, or input to Analog to Digital Converter 6 (ADC6) 

E3 Digital I/O pin, or input to ADC7 

+V Input into the onboard voltage regulator, +6VDC  to+16VDC   

VR Regulated +5.0VDC output from the onboard voltage regulator 

X1 Crystal oscillator clock pulse output terminal 

B7 Digital I/O pin 

*1 Floating pin, an alternate connection for AVCC 

*2 Floating pin, an alternate connection for AREF 

GD Ground pin 

RC Reset Capacitor conducts RTS or DTR signal to reset the microcontroller 

5. Powering Proboard PB

Users have multiple options for supplying power. 

 Connect the positive terminal of a +6VDC to +16VDC power supply to the pin marked +V, and connect
the negative terminal of the power supply to the GD connection.

 Although not recommended for full speed 16MHz operation, the ATmega328PB processor can run on
voltages as low as 3.0 volts and still function. For best timing accuracy, use +5.0VDC.

 A reduced input voltage below +5.0VDC can be applied directly to the VR terminal. It is always safest to
supply power to the +V input terminal instead, and allow the onboard voltage regulator to protect the
system.

 If a reduced voltage is applied directly to the VR terminal, the output of the onboard voltage regulator is
protected by an internal blocking diode, so the reduced input voltage on VR will not feed current back
into the unused onboard voltage regulator in such low power applications.

 Any standard TTL to USB converter can be used to supply +5VDC power to the Proboard PB.
 A regulated +5.0VDC supply can be connected to pin 2 of the ICSP programming port (J2).
 Install a Proboard PB into a Timeport accessory panel. Timeport accessory boards allow connecting

jumper wires to Proboard PB connections from either the top or bottom surfaces, and can connect to
optional Sideboard modules. Timeport boards are able to smart charge lithium polymer cells, and can
boost a lithium cell’s voltage up to a regulated +5.0VDC at 2.0 amps for powering portable projects.

https://www.heroncircuits.com
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6. Connecting

Figure 6  Using a USB to TTL Converter 

Figure 6 shows how to use a generic USB to TTL converter for transferring sketches into a 
Proboard PB. The six-pin device shown is produced by Adafruit2, but similar devices are available 
from different manufacturers. Some have the pins arranged in a different order, but devices from 
Sparkfun and OSEPP have pinouts identical to the unit shown above. We recommend using a USB 
to TTL converter that contains a genuine Future Technology Devices International (FTDI) chip, 
although other USB to TTL chips also work. 

https://www.heroncircuits.com
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Figure 7  Connecting a Polaron 

Figure 7 shows how to connect a Polaron USB to TTL converter to a Proboard PB. The cable 
shown is pictured with wires shortened for illustration. The actual cable length is about 30 
centimeters. The white plug on the right side of the cable fits into J1, which is a wire to board 
connector with 1.25mm pin spacing. 

It is not necessary to use the Polaron accessory and interconnecting cable. Many users will prefer 
to use a more generic USB to TTL converter as shown in Figure 6, but the hookup shown above in 
Figure 7 has advantages. 

If a Polaron is plugged into a laptop, and a Proboard PB is plugged into a breadboard, the 
combination places a laptop and a breadboard together on a table with simplified wiring. The 
connections at both ends of the interconnecting cable are polarized, so setups can be done without 
accidentally plugging the TTL connections backwards. Users are free to concentrate on learning 
how to control equipment connected to the microcontroller on the breadboard. 

A Polaron can provide 200mA, which is enough oomph for most breadboard projects. The device 
also includes a self-resettable fuse that limits the current that can be pulled from a computer’s USB 
port. Damage is unlikely to happen, but when connecting any equipment to a computer the user 
assumes all risk. Heron Circuits will not be liable for any damage done when connecting equipment 
to computers, but the built-in fuse and the polarized connectors effectively reduce risk. See the 
Polaron data sheet for more information. 

Interconnecting Cable 
Part Number HC60077 

Polaron 
Part Number HC40111 

Proboard PB 
Part Number HC20333

https://www.heroncircuits.com
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7. Programming

Navigate to https://www.arduino.cc/en/main/software where you can download the Arduino IDE to 
your computer. Choose the option pictured in Figure 8 if you need the Windows 10 EXE installer. 

Figure 8  Downloading the Arduino IDE  

The Arduino IDE application software will need a Heron Circuits link added. In the IDE, select 
“File>Preferences.” In the text box marked “Additional Boards Manager URLs” add this text: 

https://files.heroncircuits.com/proboard-index/package_heroncircuits_index.json 

If you already have other .json files linked in this same text box, keep them installed. Just remember 
to separate each Uniform Resource Locator (URL) with a comma. 

Select “OK.” 

Select “Tools>Board:>Boards Manager…” In the “Type” drop-down menu, select “All.” 

Feed "Heron Circuits" into the search box, and press “Enter.” 

Hover over “Heron Circuits AVR Boards.” Click “Install” and then “Close.” 

Choose “Tools>Board:>Heron Circuits Proboard PB>Proboard PB <- Crystal Oscillator.” 

The clock speed will default to 16 MHz. 

With your USB to TTL converter connected to your computer, choose “Tools>Port” and tell the 
Arduino IDE which serial port your connection has been assigned to, such as COM5, etc. On a Mac 
it will look like this: 

/dev/t ty.usbserial-A6006hSc 

Finally, upload a sketch into the Proboard PB by choosing “Sketch>Upload.” You will see the LEDs 
flash on the USB to TTL converter followed by a message in the IDE status bar: “Done Uploading.” 

Try using the “File>Examples>01.Basics>Blink” sketch. 

Click here. 

https://www.heroncircuits.com
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8. Typical Applications

 An educational tool for learning how to use sensors and actuators with microcontrollers
 Development of basic coding skills for programming microcontrollers.
 A controller for battery powered portable equipment.

9. Low Power Applications

ATmega328PB microcontrollers have capabilities beyond ATmega328P devices, but the PB chip 
designers removed an important item when designing the new chip. The previous microcontroller 
included a more robust high-amplitude crystal oscillator drive circuit. The newer ATmega328PB 
chip only has a low-amplitude crystal oscillator drive circuit. 

We ran differently packaged versions of the PB chips through variations of supply voltages, 
operating temperatures, lead length inductances and capacitances. We tried various surface mount 
board layouts connected to breadboards, and not. We tested combinations using different types of 
crystals and resonators. In the final analysis, we were unable to give the low amplitude crystal 
oscillator circuit in the ATmega328PB processor passing marks. In too many instances the 
ATmega328PB chips did not ring crystals reliably when running at a full 16 MHz clock speed. 

We solved the problem by installing an independent oscillator module. In a Proboard PB, the 
component marked “X1” is not simply a quartz crystal. It is an integrated circuit which provides high 
amplitude (5V) clock pulses on the X1 pin with an accuracy of ±10 parts per million. This provision 
is necessary for reliable and accurate instrumentation applications. 

Instructions in this section show how to configure a Proboard PB in a low-power configuration that 
does not supply power to the independent oscillator chip. A Proboard PB only uses a few milliamps 
in total when powering the independent oscillator at 16 MHz, suitable for most battery-powered 
applications, but for operating with the absolute lowest possible power consumption an advanced 
user can cut power to the oscillator by following these steps: 

1. Set the fuses of the ATmega328PB to use the microcontroller’s internal RC clock oscillator.

2. Connect the floating “Enable” contact of the Proboard PB’s X1 oscillator to ground. This cuts
the oscillator’s power.

3. Disable the Proboard PB’s green power-on indicator LED.

The next pages show how to accomplish the steps. The instructions assume a user is familiar with 
burning fuses using an In System Programmer (ISP). If not, then do not follow these instructions 
without the help of a Guru who knows how to burn fuses. Burning fuses incorrectly can brick a 
system. Bricking of a chip by setting fuses incorrectly is not covered under warranty, but if bricking 
happens as a result of fuse scrambling, it is possible to unbrick the chip by temporarily connecting 
the 16 MHz clock pulse output of a second Proboard PB to the afflicted system’s X1 pin. 

https://www.heroncircuits.com
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Figure 9  Low Power Fuse Settings 

Figure 9 shows how to complete step #1. This is the dialog box for configuring the low-power fuse 
settings for a Proboard PB when using Atmel (Microchip) Studio software and an Atmel AVR ISP 
MKII device programmer. Setting fuses in this way will cause the ATmega328PB to run at 1 MHz 
instead of the normal 16 MHz. Reducing the clock speed is a big part of what reduces the power 
consumption to bare minimum for micro-power applications. 

Fuse settings can be restored to the original 16 MHz configuration by using the Arduino IDE to burn 
a bootloader specific to a 16 MHz ATmega328PB. Default settings will use the external oscillator. 

https://www.heroncircuits.com
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Figure 10  Top Surface Configuration Options 

In step #2, the goal is to disable the 16 MHz crystal oscillator. Using the fine tip of a temperature 
controlled soldering iron, add a solder blob connecting the gold Enable pad shown in Figure 10 to 
the nearby Ground connection. The nearest ground point is the nearest leg of the Reset 
pushbutton. Be careful not to form a shunt to pin 6, and avoid overheating the Reset pushbutton. 
When the X1 chip is disabled it uses no power, and the X1 output becomes an open circuit, high 
impedance, so the X1 pin becomes a general purpose digital I/O pin. 

In step #3, the goal is to stop current from flowing through the green power-on indicator LED. You 
can cut the exposed gold trace located between the LED and the nearby resistor. If you decide to 
reactivate the LED, place a solder blob reconnecting the green LED to the resistor. When soldering, 
be careful not to overheat the LED or the resistor, and avoid shunting the RX or RC pins. 

Figure 11  Detail on the LED Connection Trace 

Reset           Ground         Enable 

Green LED Connection Trace 

https://www.heroncircuits.com
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10. Additional Resources

Related Products: 

https://files.heroncircuits.com/documents/Proboard_328P_Datasheet.pdf 

https://files.heroncircuits.com/documents/Proboard_21J_Datasheet.pdf 

https://files.heroncircuits.com/documents/Timeport_Datasheet.pdf 

https://files.heroncircuits.com/documents/Polaron_Datasheet.pdf 

11. Notice

IMPORTANT NOTICE – PLEASE READ CAREFULLY 

Heron Circuits reserves the right to make changes, corrections, enhancements, modifications and 
improvements to Heron Circuits products and/or to this document at any time without notice. Purchasers 
should obtain the latest relevant information on Heron Circuits products before placing orders. Heron Circuits 
products are sold pursuant to Heron Circuits’ terms and conditions of sale in place at the time of order 
acknowledgement. 

Purchasers are solely responsible for the choice, selection, and use of Heron Circuits products and Heron 
Circuits assumes no liability for application assistance or the design of the Purchaser’s products. 

No license, express or implied, to any intellectual property rights is granted by Heron Circuits herein. 

Resale of Heron Circuits products with provisions different from the information set forth herein shall void any 
warranty granted by Heron Circuits for such product. 

Information in this document supersedes and replaces information previously supplied in any prior versions of 
this document. 

https://www.heroncircuits.com

